Integrations

AppMap and AppMap Cloud work with the following programming languages and popular programming tools.

Code editors

Languages and frameworks

Java

  • Java 8 and newer, Oracle and OpenJDK distributions
  • Spring Boot
  • JUnit, TestNG
  • Plugins for Maven and Gradle

JavaScript

AppMap for JavaScript is currently in Open Beta. Requirements:

  • Unix-like OS (Windows is coming soon)
  • Node.js 14, 16, 17 (latest update)
  • Express.js 4.x
  • mocha>= 8.0.0
  • Supported DB drivers: mysql, pg, sqlite3

Python

  • Python 3.6 and newer
  • Django, Flask
  • pytest, unittest

Ruby

  • Ruby 2.6, 2.7, 3.0
  • Rails 5, 6
  • RSpec, Minitest, Cucumber

Source code repositories

  • GitHub
  • GitLab

Other tools and frameworks

  • Swagger, OpenAPI 3
  • Browser extension for Chrome, Firefox

Was this page helpful? thumb_up Yes thumb_down No
Thank you for your feedback!